• 福树 / 趋势交易 / 通达信精准划线公式源码

    0 0

       

    通达信精准划线公式源码

    2016-03-23  福树

    N:=8;
     A1:=REF(H,N)=HHV(H,2*N+1);
     B1:=FILTER(A1,N);
     C1:=BACKSET(B1,N+1);
     D1:=FILTER(C1,N);{高点}
    R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S11:=R11>REF(R11,1);
     DRAWLINE(D1,H,S11,H,1),COLORBLUE;
     A2:=REF(L,N)=LLV(L,2*N+1);
     B2:=FILTER(A2,N);
     C2:=BACKSET(B2,N+1);
     D2:=FILTER(C2,N);{低点}
    T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1); U11:=T11>REF(T11,1);
     DRAWLINE(D2,L,U11,L,1),COLORBLUE;
     M:=INTPART(3*N/5);
     A12:=REF(H,M)=HHV(H,2*M+1);
     B12:=FILTER(A12,M);
     C12:=BACKSET(B12,M+1);
     D12:=FILTER(C12,M);{高点}
    R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1); S112:=R112>REF(R112,1);
     DRAWLINE(D12,H,S112,H,1),COLORRED;
     A22:=REF(L,M)=LLV(L,2*M+1);
     B22:=FILTER(A22,M);
     C22:=BACKSET(B22,M+1);
     D22:=FILTER(C22,M);{低点}
    T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1); U112:=T112>REF(T112,1);
     DRAWLINE(D22,L,U112,L,1),COLORRED;
     VAR1111:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
     VAR2222:=CROSS(VAR1111,0.9);
     VAR3333:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
     VAR4444:=CROSS(VAR3333,0.9);
    压力:= REF(HIGH,BARSLAST(VAR2222));
     STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2222)),REF(HIGH,BARSLAST(VAR2222)),0.5,1),COLOREA91B5,LINETHICK3;
    支撑:= REF(LOW,BARSLAST(VAR4444));
     STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4444)),REF(LOW,BARSLAST(VAR4444)),0.5,1),COLOR00B4FF,LINETHICK3;
    下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
     RRRSV:=SMA(下档线,3,1);
     KKK:=SMA(RRRSV,3,1);
     DDD:=((3 * RRRSV) - (2 * KKK));
     JJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
     RSV24:=SMA(JJ12,3,1);
     K24:=SMA(RSV24,3,1);
     D24:=((3 * RSV24) - (2 * K24));
    压力2:=IF(CROSS(D24,DDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDD)))),COLORFFFFFF;
    压力位:=IF(ISLASTBAR,压力2,DRAWNULL);
     STICKLINE(ISLASTBAR ,压力位,压力位,120,0),LINETHICK4,COLORFFFFFF;
    底部:=LLV(HIGH,30),COLOR00FF00;
    底部位:=IF(ISLASTBAR,底部,DRAWNULL);
     STICKLINE(ISLASTBAR ,底部位,底部位,100,0),LINETHICK4,COLOR00FF00;
     

    通达信精准划线公式源码

      本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里 或 拨打24小时举报电话:4000070609 与我们联系。

      猜你喜欢

      0条评论

      发表

      请遵守用户 评论公约

      类似文章 更多
      喜欢该文的人也喜欢 更多

      浩博官网网址